Home Forum Blog Market Events Resources
Showing results for 
Search instead for 
Do you mean 
Highlighted
Frequent Contributor
Posts: 104
Registered: ‎06-14-2007

Deploying apps that integrate with SharePoint service instance - ListSetting error

Greetings.  We have a solution that is built using multiple data sources.  We use a SharePoint 2016 (on-prem) library for storing document attachments.  The majority of the solution is SQL and Oracle.  We registered the site collection via the K2 for SharePoint app from the web app's app catalog.  Doing that basically creates and configurs an instance of the 'SharePoint 2013' service broker.  We did not 'appify' any lists or libraries by going through the ribbon to generate objects.  We have a standard SmartObject in a different category that was configured to integrate with one of the service methods that was automatically generated in the SharePoint service instance.  This is basically like adding a new method to an existing SmartObject that calls a SQL service method, AD, or anything else for that matter.  

 

The problem is this:  We cannot package this SmartObject because it throws a 'ListSetting' not found error in P&D.  I understand that SharePoint-based artifacts should be packaged via the K2 button in a list/library ribbon - but the problem is that there is nothing there to package.  We just added a service method call to an existing SmartObject.  It isn't even in the same category as SharePoint artifacts.  

 

What are the deployment options for this type of scenario?  Thanks.

5th Method
http://www.5thmethod.com
Moderator
Posts: 262
Registered: ‎04-22-2014

Re: Deploying apps that integrate with SharePoint service instance - ListSetting error

Hi,

 

I'm curious how did find the method to access your list without first appifying your list? If I only run through the registration wizard, I an only find the Management and Taxonomy service objects under my SharePoint 2013 service instance.

 

It will help if you can provide more information on what service instance you are using, and what service object methods you have added into your custom SmartObject. And what exactly does your SmartObject do? Insert a new list item, modifying an existing list item, or retrieving a new list item?

K2 will not accept any liability for any issues arising from actions taken in respect of the information provided by any forum member.
Frequent Contributor
Posts: 104
Registered: ‎06-14-2007

Re: Deploying apps that integrate with SharePoint service instance - ListSetting error

Just the act of registering the site collection is what created all the service objects within a new 'SharePoint 2013' service instance.  The we added a new method to an existing SmartObject that just invoked one of the service instance methods to upload a document to a document library. We did not go into the library itself and generate forms/workflows/SmartObjects/reports - we just wanted a service method.  It all works fine, we just can't P&D it to move it over to UAT.

5th Method
http://www.5thmethod.com
Moderator
Posts: 239
Registered: ‎03-22-2013

Re: Deploying apps that integrate with SharePoint service instance - ListSetting error

Hi,

 

Did the SharePoint 2013 service instance refresh manually or register from SmartObject Tester tool?

In my test, the only way to get a new SP list to show up as a new service object under existing 2013 site collection service instance is to appify K2 app to the list.

 

K2 will not accept any liability for any issues arising from actions taken in respect of the information provided by any forum member.