Home Forum Blog Market Events Resources
Showing results for 
Search instead for 
Do you mean 
Highlighted
Occasional Contributor
Posts: 5
Registered: ‎04-01-2014

Help: Adding web service reference in a K2 Blackpearl 4.7 Workflow Project

[ Edited ]

Hi all,

 

I'm currently developing K2 processes using K2 (4.7) for Visual Studio with VS2015 on Windows 8.1.
But I can't seem to be able to add a web service reference...
I click the "Process References" button, click "Add", and the I go to the "Web" tab, insert the web service URL , and click discover.
I promptly get a "Web service discovered successfully. Press 'select' to add as a reference" response. But when I click "Select" nothing happens...

 

K2_AddWebReference_Error.jpg

 

I already uninstalled/installed again K2 4.7 client tools and VS2015 without a change of behavior...

 

Any ideas to what it might be or what can I do to debug this behavior?

 

PS: If I use K2 Studio, the behavior is the same...unfortunately...


Thanks all.

Occasional Contributor
Posts: 5
Registered: ‎04-01-2014

Re: Help : Adding web service reference in a K2 Blackpearl 4.7 Workflow Project

This is the error I get if I try to add the reference as a service:

 

Add Reference As Service Error

Occasional Contributor
Posts: 5
Registered: ‎04-01-2014

Re: Help : Adding web service reference in a K2 Blackpearl 4.7 Workflow Project

Hi all,

 

If no one can help me in my problem, can someone at least help me find another way to integrate a web service into my process using VS2015 ...maybe using smart objects...

 

The K2 4.7 version I'm using is  4.16060.2000.3

 

Thanks in advance

 

 

Valued Contributor
Posts: 566
Registered: ‎05-29-2007

Re: Help : Adding web service reference in a K2 Blackpearl 4.7 Workflow Project

Hi

 

Not sure about the issue of not being able to add a reference with K2 4.7 in Visual Studio.  However, its probably not the best way to try and integrate with web services anyways.  Exposing the web service through SmartObjects if much more flexible.

 

Take a look at the End Points Web Service Service Object.

https://help.k2.com/onlinehelp/k2blackpearl/UserGuide/4.7/default.htm#ServiceBrokers/EndPoints/EndPo...

 

As well here is another video which is a demonstration of how to use it and will probably make much more sense than your first read through the documentation.

https://www.youtube.com/watch?v=2rdn2wo0PhI

 

Regards,

Tim

 

Tim Knechtel
K2 Insider
Caprivi Solutions
http://www.caprivisolutions.com
Join K2's Renier Britz as he walks through an end-to-end demo of the new Endpoint Service Broker
Community Manager
Posts: 113
Registered: ‎04-20-2009

Re: Help : Adding web service reference in a K2 Blackpearl 4.7 Workflow Project

Hi, 

What is your current .NET Framework?
I have seen this before where the error is thrown when on .NET 4.5 and adding a service reference.

Try rolling back to .NET 4.0 or use "EndPoint WCF"

 

Regards

 

K2 will not accept any liability for any issues arising from actions taken in respect of the information provided by any forum member