Home Forum Blog Market Events Resources
Showing results for 
Search instead for 
Do you mean 
This widget could not be displayed.
This widget could not be displayed.
This widget could not be displayed.

IBM i or AS400 Service Broker

by ‎11-15-2013 10:45 AM - edited ‎04-27-2017 09:54 PM

K2 IBMi-AS/400 agent is an add-on to K2 blackpearl® allowing to create K2 SmartObjects that make use of information stored in DB2 database and files on IBMi-AS/400, without writing code and in a few clicks. SmartObjects can then be used to build K2 processes, smartforms and .NET-based applications. The main features of K2 IBMi-AS/400 agent are:

  • Access to DB2 database and IBMi-AS/400 files via Easycom® and a K2 dynamic objects service.
  • Configuration of libraries and/or tables accessed by the K2 o...

Comments
by PSwanepoel
on ‎04-15-2015 01:35 AM

Good Day I Installed the Service broker and Added it via Broker Management Console. Getting this error when Trying to register a Service instance

Error.png

 

by AvindKumar
on ‎09-01-2015 12:08 AM
Hi , Could you please share a proper document and step for this . we are not able to use this . - Arvind
by
on ‎09-01-2015 01:27 AM

Hi Arvind,

 

Could we have more details on the issues you faced ?

 

Cheers,
jan

by AvindKumar
on ‎09-01-2015 01:48 AM
Hi Jan, Thanks for reply , Do you have any documentation how to configure this ? I am getting below log. -- Easycom IBM i Installation -- -- Version: 4.70.34 -- Connecting on server '10.1.16.207' 220-QTCP at CBDRP2. 220 Connection will close if idle more than 5 minutes. Sending user ID and password 331 Enter password. 230 CRDB logged on. Checking OS/400 version 215 OS/400 is the remote operating system. The TCP/IP version is "V7R1M0". Checking previous version (1/2) - CRTSAVF FILE(QTEMP/TINS_CHK) 250 Command CRTSAVF FILE(QTEMP/TINS_CHK) successful. -- Sending file easy450v.bd into QTEMP/TINS_CHK -- 2012-08-22 10:53:22 200 Representation type is binary IMAGE. 250 Now using naming format "1". 227 Entering Passive Mode (10,1,16,207,210,36). 226 File transfer completed successfully. - RSTOBJ OBJ(INS_CHK) SAVLIB(QTEMP) DEV(*SAVF) SAVF(QTEMP/TINS_CHK) RSTLIB(QTEMP) 250 Command RSTOBJ OBJ(INS_CHK) SAVLIB(QTEMP) DEV(*SAVF) SAVF(QTEMP/TINS_CHK) RSTL successful. Checking if sufficient rights - QTEMP/INS_CHK LIB(EASYCOMK2) WHAT(EAC_INSTCAP) NO Checking previous version (2/2) - QTEMP/INS_CHK LIB(EASYCOMK2) WHAT(CHKLIB) Not found - QTEMP/INS_CHK LIB(EASYCOMXMP) WHAT(CHKLIB) Not found - Arvind Kumar
by AuraEquipements
on ‎09-01-2015 02:55 AM

Hello Avind,

 

It seems like the AS400 user profile you're using does not have the requiered rights to install the product.

You have to use a profile with *SECADM rights, using the QSECOFR user profile is recommended.

For more information you can email us the whole log at teach@easycom-aura.com

 

Sincerely,

Tanguy

by AvindKumar
on ‎09-01-2015 03:23 AM
Hello Tanguy, I am installing the product on K2 server not on DB2 server . could you tell me where do i need to install this product ? Arvind
by yanL
on ‎10-07-2015 09:38 AM

Hi,

I am trying to install this on the K2 server, but got the following error:

Installing files in /usr/local/Easycom ...
- QTEMP/INST_SC STEP('INSTIFS1') SRC(EASYCOMK2/EASYSAVF) PARM('') RMT(N)
ERR.Error during installation with message CPF3840: Specified file for restore operation not found.
Error occurred on command QTEMP/INST_SC STEP('INSTIFS1') SRC(EASYCOMK2/EASYSAVF) PARM('') RMT(N.
ERR.Error during installation with message CPF3840: Specified file for restore operation not found..

 

Could you please explain what I am missing?

 

Thanks,

Yan

by K2_Beginner
on ‎11-14-2017 01:40 PM

Hi,

When I try to download files, I get error "An invalid set of parameters has been specified in the url. "