Home Forum Blog Market Events Resources
Showing results for 
Search instead for 
Do you mean 
Highlighted
Contributor
Posts: 77
Registered: ‎09-27-2012

Unable to Deserialize Value

[ Edited ]

After successfully adding a Web Service to the End Points web service and generating SmartObjects, anytime I try to run the service I get an error "Unable to Desrialized Value SmartobjectName". 

 

I have tested this Service and it works.

 

K2 is expecing a single string a input parameter so I paste the entire XML as the parameter but always get the same error. Methods exposed are Read and Read to Serialized item

 

Could it be the Header we're using?

 

If I use the methods exposed in Object Types I find Serialize and Deserialize methods but they just give the same error "Unable to Desrialized Value SmartobjectName"

 

Assistance required.

 

Thanks. 

Moderator
Posts: 51
Registered: ‎03-11-2014

Re: Unable to Deserialize Value

Hi Latte,

 

Would you mind perhaps addidng some screenshots of the execution?

In the ServiceInstance, is there a debug property? If so can you switch it to TRUE and try again, this should give a full error message

 

-Jean

Contributor
Posts: 77
Registered: ‎09-27-2012

Re: Unable to Deserialize Value

[ Edited ]

Hi, 

 

Thanks for the reply. 

 

The error after debugging is "Unexpected character encountered while parsing value: <. Path '', line 0, position 0". We are using the same value with SOAPUI and getting a valid response from the API. 

 

Sample of the data sent is:

 

<soapenv:Envelope xmlns:soapenv="http://schemas.xmlsoap.org/soap/envelope/" xmlns:scat="http://scats.mann.com/service/scatSAccService">
<soapenv:Header/>
<soapenv:Body>
<scat:CREATE_FSFS_REQ>
<scat:scatS_HEADER>

</scat:scatS_HEADER>
<scat:scatS_BODY xmlns="http://scats.mann.com/service/scatSAccService">
<scat:Cust-Account-Full>

</scat:Cust-Account-Full>
</scat:scatS_BODY>
</scat:CREATE_FSFS_REQ>
</soapenv:Body>
</soapenv:Envelope>

 

See screenshot attached. 

Attachment
Attachment