Cannot find user in redirection form

  • 27 June 2018
  • 4 replies



We have an issue with redirecting a worklist item to another user. Via the UserManagement Smart Object, we validated that the destination user exists.

We also verified that the destination user has start/view/view participate privileges on the workflow through AAD groupmembership. The destination user does not have out-of-office configured.


We validated that the worklist item can be redirected to another user. We have tried via the worklist webpart and K2 Management Portal.


Is there an explanation why this is not working for this destination user? Other things we have to check?


Thanks in advance.


Kind regards,


4 replies

Userlevel 6
Badge +15



It sounds like the user is not correctly cached in K2. Could you check if the user can get to K2 Workspace or K2 Management site? 

You could try UMUser SmartObject to confirm this.

1. K2 Management site > Integration > Search 'UMUser'. 

2. Select the UMUser SmartObject and hit Execute.

3. Select method: Get Users method and provide Label Name (AAD). You can also try the Get User Details method . It will be in this format,





thanks for your response. I am able to get the user details by using the GetUserDetails method of the UMUser smartobject. When comparing the result with other users, I do not see a difference, meaning that the same fields are filled.


Other things I can check?




Userlevel 6
Badge +15



Could you test the User Role Manager Client User Group SmartObject's List method and see if it's getting back the problematic user?

The required Security Label parameter is AAD.



I have verified that I could find the account in that SmartObject result as well. Odd thing is that I tried to redirect to that user again and it works now? Don't know why or what triggered it, but it worked.


Many thanks for your feedback, I learned a lot troubleshooting the issue.


Have a nice weekend!