Solved

K2 Appit problems/bugs


Hi, 

  

 I have faced this issue thrice now. I am not able to access any feature of appit for 3-4 hours and trying to access them only throws exception. 

 

I am posting a couple of screenshots :

 

This is while trying to open a workflow, something similar also pops up when trying to open reports from the default page of appit, or trying to browse through items in the management console.

 

  1. Trying to access the worklist throws something like 

 

ID4223: The SamlSecurityToken is rejected because the SamlAssertion.NotOnOrAfter condition is not satisfied. NotOnOrAfter: '7/3/2014 11:12:58 AM' Current time: '7/3/2014 11:19:13 AM'

  • Type:

System.IdentityModel.Tokens.SecurityTokenExpiredException

  • Source:

System.IdentityModel

  • Stack Trace:


at System.IdentityModel.Tokens.SamlSecurityTokenHandler.ValidateToken(SecurityToken token)

at SourceCode.Security.Claims.ClaimsResolver.ValidateSaml11TokenXml(String tokenXml, List`1 issuers)

at SourceCode.Security.Claims.SecurityClaims.ResolveClaimsToUserFullyQualifiedName(ClaimsTokenType tokenType, String tokenXml, Object issuers, Object claimTypeMappings)

at SourceCode.Hosting.Server.Runtime.HostSecurityManager.GetClaimsUserName(String tokenXml, ClaimsTokenType tokenType, ClaimsVersion claimsVersion)

at SourceCode.Hosting.Server.Runtime.HostSecurityManager.AuthenticateIIdentitySession(String sessionCookie, String tokenXml, ClaimsTokenType tokenType, Boolean isPrimarySecurityEntity, String authReqSource, ClaimsVersion claimsVersion)

 

 

 

icon

Best answer by Jacob_Winters 10 July 2014, 17:53

Hello,



 



The issue you are having appears to be a caching issue which is relatively simple to fix. Clearing out your browsing history should fix the issue and you should be able to use all features. One question I would ask is what browser are you using to access Appit?



 



Regards,



JC

View original

2 replies

Hello,


 


The issue you are having appears to be a caching issue which is relatively simple to fix. Clearing out your browsing history should fix the issue and you should be able to use all features. One question I would ask is what browser are you using to access Appit?


 


Regards,


JC

I am using chrome. Thanks. I will try clearing my cache next time I face this issue :)

Reply