Solved

Choice Control Formatting Issue on SmartForm

  • 27 July 2020
  • 4 replies
  • 167 views

Badge +2

Hi All

 

Does anyone get the same issue as me whereby any formatting changes you make on a Choice control dont have any effect when you run the generated SmartForm.

 

I.e. If you change the font size, style, colour etc it changes  OK in K2 Designer but when you run the SmartForm it makes no differnce

 

thanks

 

 

icon

Best answer by paulsturmey 3 August 2020, 23:02

the issue was logged with K2 support and they confirmed this is a bug with the Choice control (cloud version).  It will be fixed in a future release.  For the time being I will use a check box list as a workaround

View original

4 replies

Hello  @paulsturmey ,


 


You might be loading the cached version of the Form. If you clear your browser cache, then do you see the changes reflected in runtime? The following can also be used to clear the SmartForms cache:


<K2 SmartForms URL>/Runtime/CacheControl.ashx?m=Clear

 


 


Regards,


Kimberly 


K2 will not accept any liability for any issues arising from actions taken in respect of information provided by any forum member.
Badge +2

Hi Kimberly

 

Thanks for reply.

The browser cache and smartform cache have both been cleared but doesnt clear the problem.

Have also tried on different browers and get the same results

 

regards

Paul

Userlevel 1
Badge +5

Hi,


You can try "checking-in" the form after the changes were made if you havent checked in already.


Hope this helps.


 


K2 will not accept any liability for any issues arising from actions taken in respect of information provided by any forum member. 

Badge +2

the issue was logged with K2 support and they confirmed this is a bug with the Choice control (cloud version).  It will be fixed in a future release.  For the time being I will use a check box list as a workaround

Reply