Solved

executing bapi in test cockpit produces value_not_fltp error

  • 12 August 2020
  • 2 replies
  • 159 views

Hi.

Hope someone can help with this. I've been struggling with testing this bapi.

I am trying to run a SAP BAPI, MEASUREM_DOCUM_RFC_SINGLE_001, in the K2 Connect test cockpit. I am getting a RfcInvoke failed(RFC_ABAP_EXCEPTION): VALUE_NOT_FLTP error.

This is occurring when I enter a value, for example, 35.12 as the RECORDED_VALUE. If I enter 3512 it works. Entering 35 works but 35.00 doesn't.

The bapi works fine entering 35.12 from within SAP via transaction SE37

As an aside, I had trouble with the READING_TIME before discovering that hhmmss is the expected format rather than hh🇲🇲ss.

Cheers

Ian 

icon

Best answer by macca 13 August 2020, 00:49

Hi.

Google is my friend

using a comma has resolved this

Cheers

RECORDED_VALUE is transferred in CHAR format. If the field contains decimal places, these must be separated using a comma or period according to the setting in the user master

 

View original

2 replies

Hi.

Google is my friend

using a comma has resolved this

Cheers

RECORDED_VALUE is transferred in CHAR format. If the field contains decimal places, these must be separated using a comma or period according to the setting in the user master

 

Possibly a better soution is to change the user profile. Transaction SU01, Defaults tab. Set the decimal notation as required. This was the solution implemented in my case.

Reply