K2 Process Error Notification Service Version 3 (K2 PENS)

Badge +1

The K2 Process Error Notification Service is a Windows Service which monitors process instances on the K2 blackpearl Server and notifies stakeholders via e-mail when new process errors are detected. How it works The software is installed as a Windows Service. Every minute the service will retreive all new errors for the specified K2 Error Profile and sends an e-mail to the e-mail adresses that are configured for notification. Each error has an unique ID. If a retry is performed by an administrator or the process is set to another activity the error is ?resolved?. Although the process can fall into the same error for the same activity, K2 generates a new error with a new ID and therefore the service will send a notification for this error. For a complete list of changes in version 3 see the manual.

28 replies

Badge +5

Good day,


I've been using the tool in all our environments and it works great!

However, I've been getting the following error from K2 recently and since getting this error I'm no longer getting my error notifications:

1 26023 Process instance 28835 not found for K2:Domaink2services at


Do you know what  could be causing this and how to ensure this does not stop the notifications from being sent?


Please advise.


Thank you,


Please let me know on how to download this tool. I am not able to download the K2 PENS .
Hello, Where do you download K2 PENS? Thanks, Tanya

I'm having trouble with this tool.  I've configured it correctly (I believe) and have successfully sent a test email from it, however it still isn't sending emails despite seeing errors in the K2 workspace error list.  I have no process specific email notifications.  The service is running under the same account as the K2 service, and the interval is set at the default (1).  I've confirmed the service is started too.  


Is there an error log for this tool that I could check for errors that would prevent it from sending emails as expected?



I am getting two types of errors recorded in the event log:



  1. K2:DOMAINK2service does not have permissions to open the process

  2. Process instance xxxxx not found for K2:DOMAINK2service

No email notifications are received as a result of these errors.


The first error is partially resolved by granting the service account admin rights to the process(es) and retrying. However there are some instances when this is not fixed.


The second error usually corresponds to an error when starting an IPC process. These errors have to be  fixed before the Notification Service can send notifications. Some of these errors are easy to fix such as those of the nature "K2:DOMAINK2service does not have permissions to Start Process N". Some can't be simply fixed such as "IPC Failed to Start: Input string was not in a correct format".

In the situation when these two types of errors cannot be resolved the options are to delete the process instance(s) (not possible in a Production environment) or create an Error Profile to exclude those process instances causing those errors.


aeberhar - you can view any errors in the Windows event log. If you checked Log Extra Info in the Log and Service Settings tab of the configuration utility all info messages will be logged in addition to errors.




Very very cool.


I want to mention a few things:

  1. Installation from a MSI


  2. Excellent documentation
  3. It works great (tested on 4.6.7)
  4. Generated email are configurable thru XSLT
  5. The provided XSLT to generate the email is not bad at all
  6. The configuration tool contains a tab to test the settings which is very handy.

I think a few options should be used whenever the SMTP requires authentication (SSL) for instance. But beside that it is great.

A big thumbs up for pblommendaal and thanks a lot for sharing.


i've got the same error like JohanL. how can i resolve it ? 

Thanks ! 



I am seeing an issue with email being sent. I have a list of email addresses seperated by a ; but it only ever sends to the last email address in the list. Has anyone else experienced this issue before?


Thank you very much,


I cannot actually seem to find this to download it. Can someone direct me. This site has not been as friendly to use since the change to this format.

I have same error as kennyC.


Any ideas?

Fixed this by installing under the network account. Then after installation , change the service log details to the k2 admin and this fixed the issue.



Now have an issue only on the production box. It is confured and tested the emails, but I do not recieve any emails at all. The log says , K2 Process Error Notification :: Started error notification job at: Tuesday, 3 February 2015 : 2:46:57 PM , but I recieve no emails.  HELP!!!

There is a big link to either login first to download or just simply download.



I moved the PEN to another server but now it stops sending notifications every day or every other day.  The service is running fine, but it seems that the K2ProcessErrors.xml does not get overwritten at some times, or just locked.  Deleting the K2ProcessErrors.xml file fixes issue, but I cannot keep doing that all the time.

Any idea?



Hi Mendal, We are trying to utilize this tool in 4.6.10 version of k2 but we are not getting any notification even after successful configuration . - Arvind
Hi Mendal, We are trying to utilize this tool in 4.6.10 version of k2 but we are not getting any notification even after successful configuration . -Arvind


the service seems to have stopped after we upgraded to version 4.6.11.  I downloaded and installed version 3 of PEN.  No emails coming.  the Windows event log shows an error source is SourceCode.Logging.Extension.EventLogExtension:

1 28018 K2:<k2 admin account> does not have permissions to open the process


Any idea how to fix this issue?



Badge +8

I have seen in the past, that sometimes it is necessary to explicitly grant the service account Admin (or at least View) rights on workflows.

In this case, I would recommend you give the "k2 admin account" View rights. If that doesn't work, try Admin instead.



Thank you Gail.  I verified in Workspace that the service account I am using has Admin/Export/Impersonate rights.  I ran K2 Workspace as the service account with no issue.  Any suggestion?



Badge +8


It sounds like you are referring to server-level permissions. I would try setting those permissions at the workflow level. Having Admin rights on the K2 server does not translate to having Admin rights on a specific workflow.



Thanks Gail.  How do I set the Workflow level permission?  Will I have to visit every workflow and then re-deploy?

I verfied that the PEN Service is running fine on another 4.6.11 environment with the same workflows.   So I am probably missing some rights I am not aware of.  What do you think?

Badge +8


Workflow (or Process) Permissions are set within the Management Console. You do not have to redeploy anything to set these permissions.

Please see: http://help.k2.com/onlinehelp/K2blackpearl/UserGuide/current/Reference-WS_MCon-Workflow-Processes_ProcessRights.html




Thanks for the link, it was helpful; rights are fine in management console's workflow. 

Anything else I can check?




Sorry, Mohamad. I was really hoping it was process rights. 

If I find anybody around here with more experience with this project, I'll see if I can get them to respond.

Best regards,


Hi Peter,


K2 Support has had a few customers experience an issue where memory consumption by the lsass.exe process on the K2 server steadily increases over time when the PENS service is running. In both cases the issue started occurring after upgrading to blackpearl 4.6.11. Have you see anything like this?