Show Runtime Spinner Custom Control

  • 9 November 2015
  • 8 replies
  • 5358 views

Userlevel 1



8 replies

Control installation instruction is missing.

 

I used standard custom control installation instruction. Control did not work with it. It does not get placed on view or form and no event appear for the control.

I take it back. There are some extensions and images blocked in our domain. This is the reason control was not being rendered on the view/form. After allowing these extensions/images on the server control worked as desired. So all is well in my world again.

Hi, Will this work for SmartForms version to 4.6.11 ?

When I try to register using controlutil.exe I get the following error:

 

D:Program Files (x86)K2 blackpearlBin>controlutil.exe register -assembly:"D:Program Files (x86)K2 blackpearlK2 smartforms DesignerinSourceCod e.QA.Controls.Modalizer.dll" SourceCode SmartForms SDK Command-Line Utility Connecting to Integrated=True;IsPrimaryLogin=True;Authenticate=True;EncryptedPassword=False;CachePassword=True;Host=localhost;Port=5555...

Loading assembly: D:Program Files (x86)K2 blackpearlK2 smartforms DesignerinSourceCode.QA.Controls.Modalizer.dll

Loading assembly: D:Program Files (x86)K2 blackpearlK2 smartforms DesignerinSourceCode.QA.Controls.Modalizer.dll

System.IO.FileLoadException: Could not load file or assembly 'file:///D:Program Files (x86)K2 blackpearlK2 smartforms DesignerinSourceCode.QA.Co ntrols.Modalizer.dll' or one of its dependencies.

Operation is not supported. (Exception from HRESULT: 0x80131515) File name: 'file:///D:Program Files (x86)K2 blackpearlK2 smartforms DesignerinSourceCode.QA.Controls.Modalizer.dll' ---> System.NotSupportedExce ption: An attempt was made to load an assembly from a network location which would have caused the assembly to be sandboxed in previous versions of th e .NET Framework. This release of the .NET Framework does not enable CAS policy by default, so this load may be dangerous. If this load is not intende d to sandbox the assembly, please enable the loadFromRemoteSources switch. See http://go.microsoft.com/fwlink/?LinkId=155569 for more information. at System.Reflection.RuntimeAssembly._nLoad(AssemblyName fileName, String codeBase, Evidence assemblySecurity, RuntimeAssembly locationHint, StackC rawlMark& stackMark, IntPtr pPrivHostBinder, Boolean throwOnFileNotFound, Boolean forIntrospection, Boolean suppressSecurityChecks) at System.Reflection.RuntimeAssembly.InternalLoadAssemblyName(AssemblyName assemblyRef, Evidence assemblySecurity, RuntimeAssembly reqAssembly, Sta ckCrawlMark& stackMark, IntPtr pPrivHostBinder, Boolean throwOnFileNotFound, Boolean forIntrospection, Boolean suppressSecurityChecks) at System.Reflection.RuntimeAssembly.InternalLoadFrom(String assemblyFile, Evidence securityEvidence, Byte[] hashValue, AssemblyHashAlgorithm hashA lgorithm, Boolean forIntrospection, Boolean suppressSecurityChecks, StackCrawlMark& stackMark) at System.Reflection.Assembly.LoadFrom(String assemblyFile) at SourceCode.Forms.Controls.Web.SDK.Installer.Program.RegisterControlTypes(String assemblyPath, List`1 supportAssemblyPaths) at SourceCode.Forms.Controls.Web.SDK.Installer.Program.Main(String[] args)

 

 

Thanks.

Userlevel 1

Hi Sampy,

 

That AFAIK is due to copying directly between remote sessions.

 

Download the zip to a central share then copy the zip to the target environment. Once you've done that extract the zip and install.

 

The control was built on 4.6.11, so yes, it should work 🙂.

 

Please let me know if you still have issues: ernie.hayter@k2.com

 

Regards,

Ernie

Thanks Ernie, this control has been working for me once I figured out the restriction in our domain. One observation is, if it takes longer for the operation within Spinner control start and end, then Spinner intermittently stops spinning till the operation is complete. Gives false impression to end user as if something is hung. But actually it is not.

Userlevel 1

Hi Noor,

 

My control actually uses the internal spinner logic of SmartForms (I literally ask SF runtime to show its spinner - I don't add it myself) - you will see the same thing happens with the native SF spinner as well.

 

It is unfortunately a known issue, and it will be easily reproducible using pure JavaScript without K2 :(

 

I don't know if we will ever move to a "multi-threaded" model in SF, if we do, this will probably go away.

 

Cheers,

Ernie

Hi Ernie,

 

Thank you very much for explaining me that behavior and the inherent nature of it. Now I know the cause of it. Appreciate it.

Hi Ernie, Sorry for the delayed response, just wanted to let you know that I could not get the assembly register command to work even with out network team's support. Thanks for your help.

Reply