Question

k2 5.0 Installation gives an error

  • 17 August 2020
  • 3 replies
  • 91 views

Badge +6

Hello,

 

I got a new computer and I have the "fun" to install the client tools again :-(

 

Everytime it is a real PAIN (everywhere) because you KNOW it is going to be worse and worse...

 

Because of our needed support for K2 Connect in kombination with Visual Studio we HAVE to Install 4.7 first and then Upgrade to 5.0 in order to update then to 5.3 (our current version)

 

For the installation of 4.7 I get already a strange error (chinese symbols in a config file):

 

 

K2 blackpearl Setup Manager
---------------------------
The task is not complete as one or more of its dependencies failed.
Duration: 0 seconds

Installation Health
-------------------
Results are based on install done on: 17.08.20*personal details removed*:36:35
Analysis Result: Failed.

The following errors were logged as part of the install:
Could not update C:Program Files (x86)K2 blackpearlK2StudioK2Studio.exe.config. Exception: Es ist eine offene Zeichenfolgenliteral vorhanden. Zeile 14, Position 69.

Target did not complete successfully: Xml Patch: K2Studio.exe.config 1

Could not update C:Program Files (x86)K2 blackpearlK2StudioK2Studio.exe.config. Exception: Es ist eine offene Zeichenfolgenliteral vorhanden. Zeile 14, Position 69.

Target did not complete successfully: Xml Patch: K2Studio.exe.config 2

Could not update C:Program Files (x86)K2 blackpearlK2StudioK2Studio.exe.config. Exception: Es ist eine offene Zeichenfolgenliteral vorhanden. Zeile 14, Position 69.

Target did not complete successfully: Xml Patch: K2Studio.exe.config 3

Could not update C:Program Files (x86)K2 blackpearlK2StudioK2Studio.exe.config. Exception: Es ist eine offene Zeichenfolgenliteral vorhanden. Zeile 14, Position 69.

Target did not complete successfully: Xml Patch: K2Studio.exe.config 4

Then I tried to update to K2 5.0 but it failed again...

 

Why is it not possible to provide ONE Setup that installs everything I need???

 

Regards,

Johann Schellenberg


3 replies

Badge +6

Hello,

 

I think the problem is related to that file:

"C:Program Files (x86)K2 blackpearlK2StudioK2Studio.exe.config"

 

<configuration>
<configSections>
<section name="sourcecode.configuration" type="SourceCode.Configuration.ConfigurationManager, SourceCode.Framework, Version=4.0.0.0, Culture=neutral, PublicKeyToken=16a2c5aaaa1b130d" />
</configSections>
<startup useLegacyV2RuntimeActivationPolicy="true">
<supportedRuntime version="v4.0" sku=".NETFramework,Version=v4.0" />
</startup>
<appSettings>
<add key="HighestSupportedTargetFramework" value="4.5" />
<add key="DefaultTargetFramework" value="4.0" />
</appSettings>
<sourcecode.configuration managerConfigFile="C:Program Files (x86)K2 blackpearlConfigurationConfigurationManager.config" productPath="C:Program Files (x86)K2 blackpearlBin" templateConfigFile="" />
<connectionStrings>
<add name="HostServer" connectionString="CHINESE CHARACTERS

it ends unexpected with chinese characters...

 

I tried to enter the connection string from my old computer:

Integrated=True;IsPrimaryLogin=True;Authenticate=True;EncryptedPassword=False;Host=HOSTNAME;Port=PORT" providerName="K2FIVE" />
</connectionStrings>
</configuration>

But I think it is not working because of the provider "K2FIVE"...

 

could anyone tell me what a working file is in K2 4.7????

 

regards,

Johann Schellenberg

Badge +6

I am a step further:

 

I removed k2 studio (i hope i do not need it...)

 

then the update to k2 5.0 is working.

 

but now I need to update to K2 5.3 but this setupt is validating and then crashes with no error message at all. I can click on next and wait for validation but it happens every time...

 

Any ideas?

Userlevel 6
Badge +15

Hi JSC,


 


Perhaps, this support KB might help (https://help.k2.com/support-services/kbt170088).


 

Reply