Hello,
our Sharepoint admins replaced the Develop and Test Sharepoint with a new installation. So we have to reinstall the K2 App for Sharepoint as well.
By running the K2 registration wizard from the App catalog we get this error:
Unable to retrieve realm for SharePoint site
The described solutions in
https://help.k2.com/support-services/kbt148364
https://help.k2.com/support-services/kbt137790
do not work.
The SP-URL ist the same but I think we have now some problems with the exisiting SP-configuration on K2 site, because the old server was connected to K2. Could this be the issue?
Andi
Best answer by AndreasG
Hi,
SYMPTOMS
After replacement/rebuild of SharePoint farm and re-deploying K2 for SharePoint app registration wizard fails on SharePoint Service Broker step with the following error:
Unable to retrieve realm for SharePoint site: https://%APP_ID%.domain.com/sites/appcatalog/K2forSharePoint
APP_ID in error message refers to the APP_ID relevant for old/decommissioned SharePoint farm and does not match one you will see in address bar.
DIAGNOSIS
References to the old app ID have are not removed from K2 database.
RESOLUTION
References to the old app ID have to be removed from K2 database. To resolve this you need to delete them from [Integration].[ProcessSharePointGeneralSetting] table as explained below:
- Backup your K2 database
- Execute the following SQL query against K2 database:
DELETE FROM [Integration].[ProcessSharePointGeneralSetting] WHERE SiteURL = -- Type in url from error message in single quotes below'https://%APP_ID%.domain.com/sites/appcatalog/K2forSharePoint'
- Restart K2 service and run K2 for SharePoint app registration wizard against
Thanks
Andi