Question

Unable to access K2 Five site locally configured anymore

  • 24 January 2020
  • 5 replies
  • 291 views

Hi all,

 

I am new with K2 Five. I was able to successfully install K2 v5.3 on my single server. And I was very happy with site URL that I got at the end of the setup installation. As all components were working(workspace, management, ...)

After I installed Active Directory on my server. My URL isn't working at all as shown in attachment. Looking forward for help!

 

Thanks,

Waleed



5 replies

Hi wak120191,


 


If you open up IIS, expand your server and the K2 site, and then click an App Pool such as 'Management,' or 'Runtime,' followed by clicking on the link to 'Browse Application' on the upper right, are you taken to the correct page?  For example, if you click on the browse link for the 'Management' app pool, you should be taken to your K2 Management page.


 


If this is the case, is the URL different than what you have in your attached screenshot?


 


Thanks


 

Userlevel 6
Badge +15

Hi wak120191,


 


To add to what chruff said, you will have to run the K2 Setup Manager and update the current Exchange Server configuration to use Exchange Online account, see below.



Another thing is to check if EWS url is accessible from the K2 server. In this case, you will log on to the K2 server (k2 service account) and browse to the Exchange Online default EWS url (https://outlook.office365.com/EWS/Exchange.asmx), I have seen sometimes, the additional server firewall setting will prevent this. 


 


If you plan to use SmartActions feature in a later state, I would  recommend taking a look at the following documentation link. For SmartActions feature to work with Exchange Online, the online mailbox must be associated with the local AD account.


https://help.k2.com/onlinehelp/k2five/icg/5.3/default.htm#Install/Manual/K2/Inst-Smartactions.htm?Highlight=smartaction


 


Apologies for the cut-and-paste here:


"When Exchange Online is used for SmartActions, the online email address must be associated with a local Active Directory Account or email actions will not fire and the following error will be reported: "System.Exception: No destinations could send the message Workflow item received.".

Userlevel 6
Badge +15

Hi wak120191,


 


It looks like a default IIS site. Are you able to browse to the K2 site via IIS? Did you install K2 on 'Default Web site'?


 


Userlevel 6
Badge +15

Hi wak120191,


 


Please ignore the exchange reply, I mean for your other post. Apologies for any inconvenience.


 

I attached image for port :443 & :81. And it isn't default server. Before enabling AD I was able to access the site on https(:443).

 

Thanks,

Waleed



Reply