Question

SharePoint Integration and SharePoint Evnets - K2 4.7 to 5.x

  • 30 May 2019
  • 1 reply
  • 123 views

Hi All,

 

We are in the process of changing our SmartObjects and Workflows to be 5.X compliant.  We currently use SharePont SmartObjects under the SharePoint Services V2 Service Object Intance.  From what I understand, this service object instance is being depreicated in version 5.x...  We are dealing with that...  I also understand that SharePoint Integration and SharePoint Events are changing.  Currently, we use a lot of the SharePoint Events in our workflows.  I also understand, that these are going away, but functionality will be avialable with SmartObject calls.   Will we have to change our WorkFlows when we upgrade to K2 5.x ??

 

Thanks in advance,

Dean


1 reply

Badge +13

Deprecated does not mean it is removed. If you are upgrading from 4.7 to 5.x, I believe the deprecated SharePoint service broker should still remain. Your SharePoint related workflows created in 4.7 should still be able to run after upgrading to 5.x. You should still have all your legacy workflow tools available. I will recommend you always test out the upgrade and check yourself if everything still works. And since the legacy components are deprecated, K2 Support no longer supports them, so if you have any issues with them, K2 Support not not be able to assist you.


 


The legacy tools and deprecated brokers will not be available if you are doing a fresh install of 5.x.


 


Another point to note is that the old SharePoint service broker no longer supports newer versions of SharePoint. If you are planning on upgrading to SharePoint 2013 and above, then you will need to use K2 for SharePoint. This means you will have to update all workflows that are using the old SharePoint service broker.


 


If you want to transition over to the new HTML5 workflow designer, then you will have to recreate all your workflows, as 4.7 workflows cannot be opened in the new workflow designer.


 

Reply