Question

Configuring Azure Application Insights with Blackpearl 4.7

  • 15 November 2017
  • 1 reply
  • 76 views

Hello K2 Community,
Does anyone have experience connecting Azure's Application Insight telemetry to bpearl 4.7?
It turns out that the core platform utilizes two .Net framework versions: 2.0 and 4.0, yet Application Insights requires 4.x and up.
So some areas of blackpearl may not be able to be covered by this app.

"Application pool 'K2 blackpearl' with .NET Framework version 'v2.0' is not supported. Only application pools running under .NET Framework 4.0 and above can be instrumented.

Trying to exchange information about the setup/configuration and the overall management experience.
Thanks!
BJ


1 reply

Any updates on this?
You mention, "Only application pools running under .NET Framework 4.0 and above can be instrumented." - Have you done this?
I am wondering if one can integrate Application Insights to k2 inline functions?!
Using Blackpearl 4.7.

Reply