Question

Deploy failed without error Message


hi,


I have designed a k2 blackpearl process with InfoPath integration. When I try to deploy the process I get the message "Deploy failed" but in the Error List there are no errors.


In the Output Window of Visual Studio I get the following message:


Build succeeded.


------ Deploy started: Project: Specialworkflow, Configuration: Debug Any CPU ------


error : The build was aborted because of an unexpected logger failure.


========== Build: 4 succeeded, 0 failed, 0 up-to-date, 0 skipped ==========


========== Deploy: 0 succeeded, 1 failed, 0 skipped ==========


30 replies

Badge +3

Didn't it work after you tried again? I already saw this, but it was nothing more than a punctual problem.


Yeah, I agree, that doesn't explain why it occurs! :-)

Unfortunately this problem occurs quite often.


I will explain the situation in a few words:
1) First deployment: the size of the Infopath is about 90kb --> deploy succeeded
2) I add more rules, views, and so on to the InfoPath form - size about 120kb --> then the problem started. Sometimes the deployment failed with a timeout error and somethimes it failed with no error.


this is quite crazy...I don't know what to do to solve the deployment problem


I have also tried to get the Infopath form smaller and to use two small Infopath forms instead of one large...but the deployment failed

Hi,


If you start k2 server in console mode you should have an error there, something like "transaction timeout" or "uncommitable transaction"...have you checked this?


Before failing, how long does the deploy take from the moment you click "finish" in the deploy wizard until you get that error? How many activities and events do you have in your process?


First thing to check is MSDTC, see if its enabled both in K2 server and sqlserver boxes and correctly configured (you can also try to increase the transaction timeout values). If its ok and the error still occurs, then you have the same problem i have :)


In some processes if the number of activities and events used goes beyond a certain number, the deploy takes around 8 or 9 minutes and then fails giving this error. if i remove some activities, the deploy still takes too much time but runs ok. I have a ticked issued for this and waiting a reply from K2!


cheers


 

Hi Jochen,


could you run K2 [blackpearl] server in console mode and let us know what it says?


I think my dev team might have run into this when MSMQ was not installed correctly.


Martin

I get a transaction timeout


Info    10530 Executing Method: 'GetSmartObjects(string[] names)' ...
Error   10520 SmartObject Runtime.Management Database Error: 'The Microsoft Dist
ributed Transaction Coordinator (MS DTC) has cancelled the distributed transacti
on.'
Error   10520 SmartObject Runtime.Management Database Error: 'The Microsoft Dist
ributed Transaction Coordinator (MS DTC) has cancelled the distributed transacti
on.'
Error   2025 Error Marshalling SourceCode.SmartObjects.Runtime.SmartObjectManage
mentServer.PublishSmartObjects, The Microsoft Distributed Transaction Coordinato
r (MS DTC) has cancelled the distributed transaction.
Error   2025 Error Marshalling SourceCode.SmartObjects.Runtime.SmartObjectManage
mentServer.PublishSmartObjects, The Microsoft Distributed Transaction Coordinato
r (MS DTC) has cancelled the distributed transaction.
Error   8060 ProcessPacket Error, The Microsoft Distributed Transaction Coordina
tor (MS DTC) has cancelled the distributed transaction.
Info    1025 Ending Session 6959D32571A42662BFF402403B7BE19E

Badge +3

Could you please tell us what your MSDTC settings are? On both client and SQL Server.

I am not sure where I can see this settings.


Can you please tell me exactly what you need and where I can get this information.


thank you

Badge +3

Sure!


Start menu --> Administrative Tools --> Component Services


In the console, expand "Component Services" --> "Computers" --> "My Computer"


Right-click "My Computer", select Properties.


In the Properties window, go to the MSDTC tab, then click Security Configuration (button on the bottom left).

thanks


here is a screenshot


Badge +3

Is it the same on both client and server?


My guess is you should tick the Enable Transaction Internet Protocol Transactions checkbox.

yes it's the same.


my system looks like this


k2 server and client is on server a
moss is on server a
database is on server b


where should I do the changes. Are there some negative siteeffects when I tick this checkbox?


thx

Badge +3

In terms of security, it's of course a bad thing to enable a new protocol on the system 🙂. This put aside, no, there's no negative side effect, as far as I know.


Oh, and I think you must restart the Distributed Transaction Coordinator service after you do the change.

jochen 


Before failing, how long does the deploy take from the moment you click "finish" in the deploy wizard until you get that


error? How many activities and events do you have in your process?


 


If you ignore the error in k2 studio and go to moss or workspace and start your workflow (by the means it is supposed to) you can run it, have you confirm this?


 

yes that's right. I can run the process. And despite the deploy failed message a new version of the process is deployed BUT the Infopath form is not updated.


 Now I have about 17 activites and about 23 events.


I think it takes neary 8 minutes from clicking the finish button until i get the deploy failed message

 My process has around 15 activities and 50 events and the deploy takes more or less those 8min and then fails.


As i said i have a ticket issued for this and i'm waiting for a reply from k2 support. when i have further news i can put here some more info.


PS: If i remove 2 or 3 activities from my process, the deploy still takes a lot of time but runs ok (you can try this also)...i hope that k2 doesn't come up with an answer that a process can only have 10 activities or so and if have more then break it in separate processes doing IPCs in between...


cheers

I got the cognition that when I create a new forms library and deploy the process and the InfoPath form into this new library the process and the form is deployed successfully despite of the deploy failed message.


But when I want to update the process and the InfoPath form the process is still updated but not the InfoPath form.


I have also told the deploy problem to the guys at k2 support and hope I will get a response very soon.

Hi,


Just a quick update on this matter. I'm still waiting for a reply to my ticket from K2, but i have seen that if i disable the option "Create Workflow Reporting SmartObjects" the deploy of my process now runs Ok in about 2min...pretty different from the 8min it was taking (and failing after)!


So just by disabling this i managed to deploy my process, but i'm not sure on the implications of disabling these option for my process.


cheers

where do I set this option?

Hi,


with the process open in K2 studio, right click on an empty surface in design canvas and choose "properties". In the window that appears click the left icon named "SmartObject Association", and then you should see 2 checkboxes, just clear the one that i mention and try the deploy of that process.

yes you are rigth. when I disable this checkbox the deploy succeeded.
disabling this option means that it is not possible to create custom reports.

Hi Jochen,


 I am getting this to.  Did you find out what caused this?


 Thanks,


 Jenny

I don't know what causes this problem. May be it is the size of the process and the size of the infopath form? But disabling this option solves this problem.


But I still have an deployment problem when the Infopath form includes too much data connection or too much rules calling the data connection. In this situation I get a time out error.


Regards,
Jochen

Hi, did you get any reply or solution on this problem?


I have exactly the same problem as yours.


Thanks.
-Ed

unfortunately I got no reply for this problem.


But now I would try do reduce the functionality in the InfoPath form. Doing as much as you can in the process. By using smartObjects or code events.
Maybe it could help you using two smal infopath forms instead of one big form.


I think the safest way would be to use asp.net pages instead of the InfoPath form.


Jochen

Reply