Question

Error when running host server

  • 27 August 2007
  • 3 replies
  • 4 views

Hi,


I get the following error when running the host server:


(The service also doesnt want to start so I run it in console mode to see what's happening)


;K2 BlackPearl HostServer Console Mode
;======================================
;Loading .NET Framework v2.0.50727
;Framework loaded successfully.
;Creating App Domain.
;Creating Host Server Runtime.
;Boot Strapping Hosting Server Runtime
;Press ESC to end..


;Error Invoking 'StartHostServer' : An error occurred creating the configuration section handler for sourcecode.smartfunctions.configsections.managerconfigsection: Could not load file or assembly 'SourceCode.SmartFunctions.Configuration, Version=4.0.0.0, Culture=neutral, PublicKeyToken=null' or one of its dependencies. The located assembly's manifest definition does not match the assembly reference. (Exception from HRESULT: 0x80131040) (C:WINDOWSMicrosoft.NETFrameworkv2.0.50727Configmachine.config line 14)



;Stopped Hosting Server Runtime


Any ideas why and how to fix?


3 replies

Badge +3

Hi,


 The same error is discussed here : http://k2underground.com/forums/thread/17940.aspx


To sum up what's been said there, just open the file indicated by the error (C:WINDOWSMicrosoft.NETFrameworkv2.0.50727Configmachine.config), go to line 14, and there you should find what causes the error:


<section name="sourcecode.smartfunctions.configsections.managerconfigsection" type="SourceCode.SmartFunctions.ConfigSections.ManagerConfigSection, SourceCode.SmartFunctions.Configuration, Version=4.0.0.0, Culture=neutral, PublicKeyToken=null">
    </section>


 Just delete this section, and this one:


<sourcecode.smartfunctions.configsections.managerconfigsection>
    <files>
      <file name="test">
      </file>
      <file name="sourcecode.smartfunctions.configuration" targetdir="C:Program FilesK2 BlackPearl Beta 2.1Host ServerBin">
      </file>
    </files>
  </sourcecode.smartfunctions.configsections.managerconfigsection>


Finally run the configuration manager again, and everything should work perfectly!

Badge +5

Hi,


This could be related to the post (http://k2underground.com/forums/thread/17940.aspx).


I think that you would be able to get it working by following the steps that Rénier suggested.


If you had Beta 2.1 installed on the same machine also follow the document attached to the thread.


Hope this helps.


Regards,

Hmmm,


thanks, missed that post for some reason,
followed it and all is good now.


Cheers


 

Reply