Question

List View, how to display AD DisplayName alongside?


Userlevel 3
Badge +13

Hi,

 

I have a List view connected to the Task SMO - get workitems method.

 

The List View shows in Actioner Name field the format K2:domainAccountID, I want to display the Actual AD Display Name in the format Surname, Forename (this is how it appears in AD)

 

I added a new Datalabel field to the List and did an expression on it to display domainAccountID (trims out the K2 part

 

i tried a Smartobject method on ADUSER SMO? using the Datalabel field as input but its not working.

 

Any step by step guides on this?

 

Thanks


20 replies

Hi,

 

you could loop over the list and use the AD-SMO Get User and set the return property Display Name to a field in your ListView.

 

Best Regards

Alex

Userlevel 3
Badge +13

Hi,

 

Already tried that:

 

For all items

then on AD User Smartobject, execute its GetUserdetails method

 

input is data label (with expression to remove the K2 part of the field)

output is Display Name to the new columb in the list...

 

Still not working. The new columb is not connected to any field,

Badge +3

Hi SharpSharp1,

 

Try to create a composite smartobject with your task SMO and UMUser SMO mapping Actioner field from Task with FQN in UMUser SMO.

 

Thanks,

Vijay

Userlevel 3
Badge +13

Hi Vijay,

 

How can i do a Composite SMO if the Values are different?

 

TASK SMO = Actioner Name format: K2:DOMAINUSERID

 

AD USER SMO = Input in format USERID and Output needs to be DisplayName

Badge +3

Hi Sharpsharp1,

 

User SMO FQN return value is in K2:domainuserid format.

is your actioner column has values in  different format?

 

Please note that this is not AD User SMO and I am referring to UM User SMO.

 

Thanks,

Vijay

Userlevel 3
Badge +13

Any chance of a step by step on doing this on the two SMOs you mentioned? I tried, but the page just gives the green spinner when doing the method mapping

Badge +3

Hi,

 

Can I know which tool you are using to build composite SMO? You must use either K2 studio/k2 for visual studio.

 

Please find the images for your reference

 

 

Thanks,

Vijay

Userlevel 3
Badge +13

Hi Vijay,

 

I am using K2 Designer (K2 4.7)

I do have access to Studio if need be.

 

Is it possible in K2 Designer by editing the Smartobject to create the Mappings/associations?

 

Thanks

Userlevel 3
Badge +13

Vijay, could you attach the test project to this post so i can try it. I take it that is K2 Studio?

Badge +3

Hi,

 

Yes,it is in K2 Studio. Please find the attachment.

 

Thanks,

Vijay

Userlevel 3
Badge +13

Thanks Vijay,

 

I deployed the project, generated a List View, then in the initalize rule - execeute the Taska Method on the View, i added on the INPUT: Label K2:, in filter i added Activity Instance Destination ID = xx

 

Result is List displays all entries for Process Instance ID, Activity Detin ID, Destination,

but Name, Dsiplay Name and FQN are empty...

 

Something missing?

 

 

Badge +3

Hi Sharpsharp1,

 

can you  execute UM User SMO in smartobject tester and see if you can get any results for that User.

 

You can find UM User SMO under User Role Manager Service Categrory/All Smartobjects 

 

Thanks,

Vijay

Userlevel 3
Badge +13

Ran tester tool on UMUSER Get User Details Method with that Username in FQN and it get the full details of the user...

 

In your CompositeMSO - ServiceObject method bindings, you have method - User: GET Users from the URM Service, is that right? Should it be Get User Details?

Badge +3

if both FQN and destination values are in same format then it should work.

 

Can you also execute my smartobject in tester with just passing label name.

 

Thanks,

Vijay

Userlevel 3
Badge +13

Ran your SMO in tester tool with just label as K2:

 

Result is Activity Instance Destination ID, Process Instance ID and Destination Populated

 

Name, DisplayName, FQN are empty

 

In your CompositeMSO - ServiceObject method bindings, you have method - User: GET Users from the URM Service, is that right? Should it be Get User Details?

Badge +3

Yes,That is right.It should be Get Users only.I tested my side and everything works fine.

 

Can you built your own smartobject and see if that makes any change.

 

Thanks,

Vijay

Badge +3

Deployed into another machine and tested-it is working.For your reference,

 

 

Thanks,

Vijay

Userlevel 3
Badge +13

Tried again, still nothing being returned for display name...

 

Anything else i can try? Or will I have to go back to use a For Loop (which takes a long time)

 

Did you configure any Associations in the SMO (it's empty in Designer)

Userlevel 3
Badge +13

Might have found the problem:

 

Can someone try running the tester tool on the UMUSER SMO with Method - Get Users

 

Enter Label Name - Required with your Label: i.e. K2:

 

Click execute...

I am getting no results..... Is that the reason why i'm not getting anything in the SMO ???

 

Should this return results?

In the tester tool it works fine, if i use a different method like Get User Details

 

Please let me know

 

Userlevel 3
Badge +13

The problem with the display name not appearing is down to the the ServiceObject Method bindings

 

The first binding is Getworklistitems: List  from K2 Management

The second binding is User: Get User Details from the URM Service

 

The second binding, has Input FQN, which i bound to Smartobject property: ActionerName

Output is set to Return property DisplayName bound to Actioner Display Name (this is a field i created to store the display name from the binding)

 

When i run this, nothing is returned, maybe a glitch or bug, but ActionerName does not appear to get passed into the FQN for it to pull out the Display Name.

 

Any ideas K2ers?

 

Thanks

 

Reply