Solved

Random servers showing up in the management console


Hi,

 

Has anyone had it in the Management Console of the K2 Workspace where servers that don't belong show up on the left?

 

The attachment is of our Development (K2DV02) environment K2 Workspace. The servers highlighted in yellow should not be there.

 

I'm wondering how is this controlled? I've tried the k2 helpfiles but haven't come up with much.

 

We are on 4.6.10

 

Thanks,

 

Rebecca


icon

Best answer by Mustafa 6 May 2016, 13:13

Hi,

 

I believe you can disable them from the Management.xml under the following path:

 

C:Program Files (x86)K2 blackpearlWorkSpaceSiteManagement.xml

 

I can't really remember the node that you need to comment out, as a test find the following node and comment it then perform an IISRESET:

 

<!-- <discoveryPorts>

<add port="49599" timeout="1000" />

</discoveryPorts> -->

hope this helps

View original

5 replies

Userlevel 6
Badge +10

Hi,

 

I believe you can disable them from the Management.xml under the following path:

 

C:Program Files (x86)K2 blackpearlWorkSpaceSiteManagement.xml

 

I can't really remember the node that you need to comment out, as a test find the following node and comment it then perform an IISRESET:

 

<!-- <discoveryPorts>
<add port="49599" timeout="1000" />
</discoveryPorts> -->

hope this helps

Thanks Mustafa, we found this K2 article http://help.k2.com/kb001221 and were hopeful that it would fix our problem.

 

We followed the steps and stopped the ISODV12 machine from broadcasting which seemed to work as it no longer appeared in the Development Management Console. However, when I checked a similar machine (with its K2 server running) the config files looked like the machine should also have previously appeared in that Management Console alongside ISODV12.

 

I'm wondering if somethign else may be preventing its broadcast from being received by the Development Management Console - or if the cause has nothing to do with discovery/the article.

 

Cheers,

 

 

Becca

 

 

Firewalls and network configuration is the most common cause of servers showing or not showing up in Workspace.

Thanks all, further testing seems to suggest that not only does the K2 server need to be running, but someone also needs to have recently navigated to the Management Console or refreshed its server list. As after a few minutes or so of inactivity, it stops broadcasting.

 

Becca

Badge

Although it has been marked as resolved, I would comment/add the following:

In order to prevent K2 Workspace different servers showing up in K2 Management (e.g. you can have a situation when both K2 farm and individual farm nodes are showing up) you need to modify  Management.xml on each of your K2 nodes (default location is C:\Program Files (x86)\K2 blackpearl\WorkSpace\Site) and edit the section shown below:

<discoveryPorts><add port="49599" timeout="1000" /></discoveryPorts>

Instead of commenting it out you can set port value to 0. This setting gets picked up dynamically without need for IIS refresh. You just need to refresh browser page to see the change.

Reply