Question

SmartObjectServer Exception: Value does not fall within the expected range.

  • 20 February 2008
  • 18 replies
  • 177 views

Badge +3

I have this problem since yesterday, and now I can't deploy any process.


The only entry in the log is:


"78392","2008-02-20 10:01:49","Error","Unknown","8060","ProcessPacketError","SourceCode.Hosting.Server.Services.TCPClientSocket.ProcessPacket","8060 ProcessPacket Error, Value does not fall within the expected range.


Has anybody a solution?


18 replies

Does this occur with a specific process or does this occur even with a simple dummy process (i.e. a process with a single blank server event)?  This is just to isolate if this is a process solution specific issue or an environment issue.


If this is occurring only within your process, do you have more information on what this process is doing?

Badge +3

It occurs with all my processes. I created yesterday a dummy process to be sure my files weren't corrupted in any way, and I got the same result.


However, I think I'm on the track of the cause as I installed this morning Blackpearl Designer on another PC, and during the configuration, the license expiry date was "15-2-2008" whereas I updated it last week (before it expired, and with the "Update license key" option of the configuration wizard).


How can I REALLY update the expiry date? (when I updated the license, the new expiry date was displayed correctly)

From what I know, there shouldn't be any licensing requirement on the Development machines.  However, as you need a valid K2 server license to execute your process, I would check if the license has been properly updated on the K2 server.  To see the license details:




  1. Stop the K2 Host server from the services console.


  2. Modify the logging config file to trace all details.
    C:Program FilesK2 blackpearlHost ServerBinHostServerLogging.config
    The following line controls the level of logging to the console, change this to "All" to log all details (including licensing).
    <LogLocation Name="ConsoleExtension" Active="True" LogLevel="All" />


  3. From Start -> All Programs -> K2 [blackpearl]. Right click on K2 [blackpearl] server and select Runas. Enter the credentials for the K2 service account and the server will run in Console Mode.

If you find that the license details are wrong, check the HostServer database.  Look into the LicenseKeys table, check that the LicenseKey value matches the one that you entered.  If it is the same, it means that you probably are using an expired key.  You would need to request a new key at this point.


I hope this info helps.  Cheers.

Badge +3

I had already loglevel set to "All" (not for the console, but for the log file), and the Expiry Date as it appears in this file is "16-3-2008", which is the new one.


I know the license is not "managed" on client computers, but when you run the config wizard on a client machine, at the end you get a summary of the config (when you attach to an existing environment), and this is where I see the old license expiry date.


It's like if the license update has not been recorded in the database. However I don't understand why I can run the Blackpearl server as usually, if it doesn't recognize the license key as valid, it refuses to start (I had an expired key on a demo VM few months ago).


Do you know if the expiry date is stored in two different locations in the Databases? Then these two dates might be different, causing my problem.

I did a check and the old expiry date issue seems to be a known issue at the moment.  It's due to some issue with the expiry date string not being updated in the Configuration table.  However, it's mainly cosmetic so it shouldn't impact the developer machine.  The error you have might be related to something else.  However, just to check, are other machines impacted or is it just this machine?  This will help us trace down whether it is an issue with the server or client machine.
Badge +3

I used only one machine for development, I've just installed Blackpearl Designer on another machine but I'm experiencing different problems due to the fact that this other machine has also Visual Studio 2008 installed on it. And you can imagine I don't have a third machine available (and unfortunately, I'm the only Blackpearl developer in my organization).

How about a VirtualPC or VMWare machine for testing?


The worse case would be to do a clean uninstall (See KB000216) and re-install back BP Studio.  As the installation is pretty quick.  It might be faster than trying to figure what setting is wrong.


From what I see, the most common issue relating to this error message is normally related to InfoPath settings.

Badge +3

Infopath settings... The K2 support team suggested the same thing. However in this case there is just a server event in a default activity and no integration at all with Infopath or Sharepoint. I'll try to reinstall today, I'd like to get rid of this issue before the end of the week!

From your description it definitely does not look like a InfoPath issue.  Let us know if the re-install fixes it.

Badge +3
I reinstalled everything on my client computer and the error is still here... I'll install Blackpearl Designer on one of my colleagues' computer but I'm not very optimistic.

Hmm, that would indicate that it might be server specific.  However, I think trying it from another machine might confirm that.


 Also if you can, log an official support ticket.  The support team will be able to help you in a more timely fashion in getting this fixed.

Badge +3

Actually, I had opened a formal support case just before I created this thread as this problem occurs in our production environment. We begin the installation on another machine. Fingers crossed.


 


[Edit] We installed it yesterday, I tested it today, and we got another problem, already referenced on K2Underground (something like "you need to define an environment", see http://k2underground.com/forums/thread/20603.aspx). I will try to reinstall but my colleague doesn't have much time for this (configuring a VM, as suggested, could be a solution but it would have to be in our domain, meaning I should involve the infrastructure guy, etc.)

Hi Nicholas, 


If possible, collect up the installation and configuration logs if there are issues.  This will help give some clues if there is something causing the failure in your environment.

Badge +3

Hi Johnny,


The K2 support team has narrowed the problem: I've been able to deploy my dummy workflow after I unticked the "Create Workflow Reporting SmartObjects" checkbox in the Association wizard.


It's not yet a resolution, as my *real* processes make use of SmartObjects, but there's definitely something bad with SmartObject management.


I'll keep you informed!

Hi Nicholas,


Just another thought here.  Could you try turning on msbuild output verbosity to Diagnostic (Tools -> Options -> Projects and Solutions -> Build and Run-> MS Build project build output verbosity) .  This might help to give more information during the build and hopefully turn up some further clues on the issue.

Ignore this. Dup post.

Badge +3

Hi Johnny,


I think our problem is "solved". The quotation marks are there because I absolutely don't know what unlocked the situation but it actually works now. I'm puzzled, really. I'll perform some other tests tomorrow and request our support ticket to be closed.


I really don't like this kind of frightening problem. It may occur again next week, or next month as I don't know what the root cause is.


Thanks for your support.

Hi Nicolas,


 That does sound strange.  However, if it happens again, do try the diagnostic tracing as mentioned earlier.  However, we can trace down the cause for the issue.

Reply