Question

Unauthorized Smartobject Access

  • 29 February 2016
  • 10 replies
  • 35 views

Hello everyone.

 

I am working on a simple workflow for approving the creation of Users in an application.  Basically, a user fills out the form and if the user has manager approval, it will proceed to send an email to IT creating an IT ticket with the form information.  If the user does nto have manager approval, the workflow will send an email to the manager to approve the request and proceed with the  IT ticket creation (or rejection).

 

Once the worklist is open for the Manager to approve, I get the following error: Unauthorized smartobject Access (screenshot of workflow and error, error below)

 

What could be causing this?  My user has admin permissions for the process as well as in the smartobjects security (Workspace). 

 

I tried looking thru the community and various articles but cant find anything I either havent tried or that applies to what I'm experiencing. 

 

 

--------------------------------------------Error

Unauthorised SmartObject access


•Type: System.UnauthorizedAccessException

•Source: SourceCode.Forms

•Method Base
◦Member Type: Method

◦Name: DecryptSmoMethodText

◦Module
◾Scope Name: SourceCode.Forms.dll

◦Declaring Type
◾Full Name: SourceCode.Forms.AppFramework.FormRuntime

•Stack Trace:
at SourceCode.Forms.AppFramework.FormRuntime.DecryptSmoMethodText(String smartObjMethodText, Guid smoGuid, String smoName)

at SourceCode.Forms.AppFramework.FormRuntime.SmartObjectExecution(XPathNavigator nav, Boolean outputDependencies, SmartObjectClientServer svr)

at SourceCode.Forms.AppFramework.FormRuntime.WorkXmlToApi(String xml)

at SourceCode.Forms.Runtime.AJAXCall.ProcessRequest(HttpContext context)

 

 




10 replies

Dear ,

 

Could u check the form? which SMO is throwing this error ? probably disabling the SMO methods 1 by 1 , until u clarify which one is throwing this error ,

also one more thing to check , im nt rly sure if this is happening with this SMO only or is it happening with all other SMO's ?

prolly u should check the permission in SQL level ? does ur user have permissions in the SQL ?

 

Hope it helps!

Regards.

Hey Ahmad. Thank you for your follow up questions. I should have mentioned that I am a beginner when it comes to K2.  I have developed only a few basic forms, etc. So by SMO I am assuming you mean Smart Objects?

The only additional smartobjects to the controller form (for the worklist item) are the approver and comments fields (screen shots attached).

I tried disabling the two additional fields but still am not able to submit without getting the 'unauthorized smartobject access' error.


Also, I have permissions for the SQL K2 Database.

 

Left out screenshot sorry


Dear ,

 

Are these SMO's off SQL data base service ? or CRM ? because i see CRM fields ,

if its CRM , i cant help much but to note that if CRM data source has permissions then u should check them out .

Also if u could provide screen shot for the permissions in workspace .

 

Regards.

Ahmad,

I am using CRM entry fields but they are not linked to CRM.  They are just taking in information, etc. The SmartObjects should be looking at the K2 database, not CRM.

Dear ,

 

Sry not sure wt would cause that , only thing i might think of since u already done everything and all permissions ,

just wondering if u r using smartobject using smartbox services , then u should check the workspace --> smartbox permissions .

 

Regards.

Badge +1

Hi! perhaps you can try the following:

 

1) Disable the rules in your forms to determine if its the Smf or the workflow portion that is throwing the SmO error

2) In your form disable the rules one by one to narrow down the SmO that is throwing the error?

 

YeeKhin

Thank you Yeekhin and team.

 

I was able to find the issue.  Was something odd within my workflow rules. 

 

Thanks again to you both!

I am getting similar error while opening a form. I have checked the rules in the form but nothing stands out. No clue what could be causing this error. I am attaching a screenshot for this error here:

 

 

 

Badge +3
What was the odd thing? A lot of us are having the same issue.

Thanks!

Reply