Question

View flow error


When double clicking on any object in the view flow, I get this error:



Client found response content type of 'text/html; charset=utf-8', but expected 'text/xml'. The request failed with the error message: --


The file you are attempting to save or retrieve has been blocked from this Web site by the server administrators.


Any ideas?


22 replies

Which browser are you using?
I get the error with IE 6 and 7.
Any chance that your browser is going through a proxy which the administrator has set some rules to filter non-approved content?
No, there is no proxy in play here because I am solely within our intranet.  However, I did find that I get this error only when I double click an object in the view flow from the K2 webpart in MOSS.  If I view the flow through the K2 workspace and then double click an object, it works fine and shows the report as expected.  Any ideas?

Ok just for fun try this


 


 


1. Open IIS and locate the Tasklist folder


2. Right Click the folder and select properties


3. Change Execute Permissions from “Scripts and Executables” to “Scripts only”


Do IISRESET just for good measure


 


It's already set to Scripts only.

Rerun the K2 [blackpearl] Configuration Manager.  When you're on the step entering the information for reporting services, be sure to enter as:  http://[hostname]:[port]   or just http://[hostname] if a specific port is not used.

The reason for the error is that the reporting services path is most likely pointing to the reporting services web front-end, which is why it's getting text/html when it's expecting text/xml.  It needs to hit the webservice, not the website.
 

Good one matt, let us know if that works Crum66...
I re-ran the configuration manager, confirming the appropriate URL for reporting services, but I still get the same error.  In the web part properties, I tried a number different combinations for the Report Server URL, but I get the same error each time.  Note that my MOSS server uses the default port (80) and my reporting services site runs on port 8000.  So in the configuration manager, I specified http://<server>:8000 for the reporting services URL and ReportServer for the reporting services virtual directory (I believe this is the right one to use, correct?).
That is correct.  Can you view any of the reports from the K2 workspace?

Yes, all the reports work just fine when accessing them through the workspace.  It's just when I double click on the view flow from the web part that I get the error.  Remember, when I double click on the view flow from the workspace, the reports show fine.


Thanks for your persistence on this!

can you post the resulting viewflow URLs from both the workspace and when you click on the webpart?  I'm just interested in url's parameters to see if something is different between the 2.

When I use the workspace, the URL of the view flow (which does work) is:


http://<server>:8001/Workspace/Tasklistcontrol/ViewFlowMain.aspx?ProcessID=89&K2Server=<server>:5252


and then when I click on Process Properties, the Reporting Services report displays just fine.  The URL of the report frame is:


http://<server>:8001/Workspace/Reserved.ReportViewerWebControl.axd?ReportSession=ary2cc2rs3tjor3mdnu3ip45&ControlID=64378b877cc245778539475d3a858f69&Culture=1033&UICulture=1033&ReportStack=1&OpType=ReportArea&Controller=ClientControllerctl02_ctl00&PageNumber=1&ZoomMode=Percent&ZoomPct=100&ReloadDocMap=true&SearchStartPage=0&LinkTarget=_top


When I use the K2 web part, the URL of the view flow (which does work) is:


http://<server>/_layouts/tasklist/ViewFlowMain.aspx?ProcessID=89&K2Server=localhost


and then when I click on Process Properties, I get the error previously mentioned.  The URL of that page/frame is:


http://<server>/_layouts/tasklist/ViewFlowReport.aspx?ProcInstID=89&ItemID=0&ItemName=&ItemType=0&ItemInstID=0&ReportPath=


Hope this helps.  Thanks.


Dave

I'm assuming you're accessing the last 2 through MOSS.

 If you edit the Worklist webpart, what is the URL listed for the report server? 
 

Yes, the last two URLs in my previous post were from the K2 Worklist web part.


The Report Server URL setting in the K2 Worklist web part is http://<server>:8000

Can you try and update the webpart so the Report Server URL reads:  http://<server>:8000/reportserver/


Let me know if that works.

When I try to change the Report Server URL, I get this message:


Cannot save the property settings for this Web Part. One or more errors have occurred. See below for details.


But there are no other details provided.  However, after going back into the properties of the web part later on, it looks like the change indeed took effect.  However, I still get the error on the view flow as described earlier.


I did find these three errors in the Application event log when I got the error when trying to make the change in the web part:


ERROR 1: 


Event Type: Error
Event Source: K2.net Task List
Event Category: None
Event ID: 0
Date:  2/8/2008
Time:  2:22:35 PM
User:  N/A
Computer: DEV0-GMRPOCVM07
Description:
Problem preparing table XML. ().


System.Xml.XmlException: Root element is missing.
   at System.Xml.XmlTextReaderImpl.Throw(Exception e)
   at System.Xml.XmlTextReaderImpl.ThrowWithoutLineInfo(String res)
   at System.Xml.XmlTextReaderImpl.ParseDocumentContent()
   at System.Xml.XmlTextReaderImpl.Read()
   at System.Xml.XmlLoader.Load(XmlDocument doc, XmlReader reader, Boolean preserveWhitespace)
   at System.Xml.XmlDocument.Load(XmlReader reader)
   at System.Xml.XmlDocument.LoadXml(String xml)
   at SourceCode.Workflow.TaskList.WebPart.Editors.ColumnEditor.CalculateXmlFromTable(String pTableText)


For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.


ERROR 2:


Event Type: Error
Event Source: K2.net Task List
Event Category: None
Event ID: 0
Date:  2/8/2008
Time:  2:22:35 PM
User:  N/A
Computer: DEV0-GMRPOCVM07
Description:
Problem setting the values to save in ColumnEditor.


System.Xml.XmlException: Root element is missing.
   at SourceCode.Workflow.TaskList.WebPart.Editors.ColumnEditor.CalculateXmlFromTable(String pTableText)
   at SourceCode.Workflow.TaskList.WebPart.Editors.ColumnEditor.GetColumnsFromColumnList(List`1 pColumns)
   at SourceCode.Workflow.TaskList.WebPart.Editors.ColumnEditor.SetAllValues(TaskListWebPartFactory& pCurrentPart)


For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.


ERROR 3:


Event Type: Error
Event Source: K2.net Task List
Event Category: None
Event ID: 0
Date:  2/8/2008
Time:  2:22:35 PM
User:  N/A
Computer: DEV0-GMRPOCVM07
Description:
Problem synchronizing changes in ColumnEditor.


System.Xml.XmlException: Root element is missing.
   at SourceCode.Workflow.TaskList.WebPart.Editors.ColumnEditor.SetAllValues(TaskListWebPartFactory& pCurrentPart)
   at SourceCode.Workflow.TaskList.WebPart.Editors.ColumnEditor.ApplyChanges()


For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.

I would definitely change it back to http://<server>:8000

 Can you open a support ticket for this?  I'm starting to think it may be a setup/configuration issue.
 

I have submitted a support ticket.  Thanks for your efforts.

replying for mr crum66 as i am sitting next to him


 We made the change and still does not work.


 It now looks like this


http://servername:8000


 


we also tried http://servername:8000/reportserver

Okay, the mystery is solved.  Since my report server was on a different port from the SharePoint server, I had to specify this in the web.config file of the SharePoint site:


In the <appSettings> section, add this line:


<add key="ReportServer" value="http://<server>:<port>/ReportServer"/>


and then do an IIS reset.


Thanks to the K2 labs team for solving this problem.


 


 

WHOOOOHOOOOO Nice work Ockert and Frank!

Reply