Question

Editable List View doesn't allow Pagination


Badge +1

Hi,

I just noticed that the “Enable Paging” checkbox is being disabled when “Enable list editing” is checked. Is there any way we can get both functions for a List View? I would need to have the Pagination and Edit function.

Thanks in advance.


11 replies

Userlevel 3
Badge +6

Hi @nicole_adona,

 

Unfortunately you cannot have both features at the same time:
 

Note: Paging is not available if the list is editable.

 

Kind Regards

Prineel

Badge +1

Thanks for the reply, @Prineel. I already know that, as per what I mentioned on my previous post. What I’m asking is if there’s any known method to somehow bypass this or probably a workaround for this?

Userlevel 2
Badge +5

Hi Nicole,

 

Seems like we do not have this feature yet. This has been submitted as a feature request on 

ideas.k2.com previously, you may refer to the below

 

https://ideas.k2.com/ideas/APIT-I-952

 

The link provided is a forum wherein you can log a new feature request or vote for other.

Everyone that works in your office can vote on the idea to get more attention from the developers .

 

Should you feel that this post is of use and or an accurate solution to the raised question, I kindly encourage you to mark it as such 


using the 'Best Answer', 'Like' and\or ‘Me Too’ options.

 

Cheers,
Kate

 

K2 will not accept any liability for any issues arising from actions taken in respect of the information provided by any forum member.
 

 

 

Badge +1

Thanks for that information, @kateV. I tried accessing the link you provided but it just redirected me to the Nintex site.

Userlevel 3
Badge +6

Hi @nicole_adona,

 

Please try this link and search for the existing post to vote on, if it does not work, you can reach out to ideas@k2.com.

 

Kind Regards

Prineel

Badge +1

Hello @nicole_adona,

 

I can understand your situation as I have been in that place before and the only thing we can do is to use non-editable list view and on click of Add/Edit, open a subview or subform and while closing the subform/subview refresh the list view.

 

Regards,

Divya Raj

Badge +1

@nicole_adona one workaround I’ve come up with to have both, list pagination and add/edit/delete functionality:

*** My workaround does require a bit more development but it works!

Deselect “Enable list Editing” and select the “Enable Pagination”

Drag and drop the toolbar buttons you need (Add the Add/Edit/Delete/Refresh) to your list view and wire up the Add/Edit/Delete rules manually.

 

See screenshot below of list view with Add and Edit functionality and Pagination (I did not add an Edit toolbar button because my user prefer to double click the record they want to edit instead):

*** I had to blur out sensitive info

 

Hope this helps!

Userlevel 3
Badge +6

Hi @lilpancho1,

 

May I ask what rules you used to add and edit?

 

Kind Regards

Prineel

Badge +1

@Prineel sorry for the delayed response.

To best explain my workaround I will provide an example. For this example lets just say I needed a form to allow users to manage inventory. 

I created an Inventory list view that uses pagination and I added the necessary toolbar buttons (add and edit) to the list view. I also created an inventory item view.

When the user clicks the add toolbar button, open the inventory item view as a sub view.

Likewise, when the user double-clicks on a record in the inventory list view (or selects a record and clicks the edit toolbar button), open the inventory item view as a sub view and transfer the existing record data to be edited. 

When the user clicks the submit button (if Add tool bar was clicked), execute inventory smart object create and close the inventory item sub view. 

When the user clicks the submit button (if Edit tool bar was clicked or record was double clicked), execute inventory smart object update and close the inventory item sub view.

 

Hope that helps! Let me know if you need more clarification.

Userlevel 3
Badge +6

Hi @lilpancho1,

 

Many thanks, I understand now. Nice work-around :) 

 

Kind Regards

Prineel

Badge +1

@Prineel 

Thank you! I had to get creative and think outside the box to accommodate requirements.

Reply