DocuSign Service Broker

  • 13 September 2013
  • 3 replies
  • 29 views

Obtaining a signature is a central part of many processes. Traditionally, getting documents signed can be cumbersome and manual. By combining K2 with the DocuSign Signature Appliance (formerly CoSign), users can apply digital signature placeholders to one or more documents, no matter how many people are involved in the signing process. The integrity of the process is maintained, and with real-time visibility into every step of the workflow, all processes can be tracked to completion.


3 replies

Used this in a little Club Memebership app that generated a PDF, and then used the CoSign sign methods to sign the document

Worked very well! once you have the webkit facility on the PDF Converter service intance (SmartForms 1.0.7), you should be able to search the PDF for your CoSign signature as well. Has lots of fun using this!

I'm trying out the CoSign Service Broker, and have followed the steps provided in the PDF that was included in the project to register the service broker. I placed SourceCode.SmartObjects.Services.CoSign.dll, Interop.SAPILib.dll and Interop.SAPIUMCOMLib.dll in the ServiceBroker directory (C:Program Files (x86)K2 blackpearlServiceBroker). I added the new service type and instance using the SmartObject tester, and created the SmartObjects. I also installed the CoSign client software on the K2 server, and configured the appliance using the configuration utility. To use CoSign's 'Create Signature Field' using K2 Designer for Visual Studio 2012, I added a SmartObject event to the canvas, and tried to expand the 'Signature Field' SmartObject, with the intention of selecting the 'Create' method, to add to the SmartObject method to be executed. When I click on the plus icon to expand, I get an error message stating that the SmartObjectDefinition schema xml is not valid. I also get an error when trying to execute the method from the tester.  Any advice would be appreciated.

hi cjmoran,

 

What version of K2 blackpearl are you running?  At least 4.6.5?

Reply