Question

Categories in Management - How to give specific permissions / access

  • 13 March 2019
  • 7 replies
  • 323 views

Hi,

 

Since we can now do the same functionalities in management as we could do using the smartobject tester tool, we want to give developers access to the "categories" are inside management console.

How can we give them access to the categories folder? Can't find that option anywhere. The Security part that appears has the default set to Allow Everyone to view,modify,execute and delete (but not to access security).

 

Thanks and regards,

Joao


7 replies

Hello Joao,

 

First thing to check is if you are logged into Management as Administrator.

 

I am not quiet sure where you are trying to access the management site from, but just to make sure, considering that you are in your VM please click here and then scroll down to SECURITY as shown on the below image.

 

 

 

 

 

 

 

I hope this post answers your question. If you find it helpful, please mark it as such by "Accept as Solution" or "Kudo" as it will be helpful to other members of the community who encounters a similar issue.

 

Regards,

Katleho

Hi Katlehon,

 

I have exactly that default configuration, and as I mentioned, it is configured for everyone to have access... 

Either way, I tried giving specific permissions to a user, but he still says he doesn't see the tab "Categories" when loading the management console.


Shouldn't everyone be able to see the "categories" tab by default?

Hello Jaoa,

 

Yes, everybody should see the categories tab by default.

 

Could you please specify the version of K2 you are working on, this will help me in the investigation of this issue.

 

Also, ensure that you (as adminisrator) have ADMIN server rights. Maybe you dont have the SECURITY option due to a lack of server admin rights.

 

Regards,

Katleho

 

 

 

 

Hi Katlehon,

 

We are testing the version 5.2 with fixpack 23.

I have admin access with the service account. I do see all the options, including the security part, with the service account.

 

Regards,

Joao

Is anyone able to help me out?

 

Thanks,

Joao

Hi Joao

 

The following links will help you to set permissions

Step1:if you are using (k2 4.7) follow bellow link:

https://help.k2.com/onlinehelp/k2blackpearl/userguide/4.7/default.htm#6.Administer/Workspace_Legacy/Rights_and_Permissions.htm  or click HERE

https://help.k2.com/onlinehelp/k2blackpearl/userguide/4.7/default.htm#K2_Management_Site/Integration/SmartObjectSecurity.htm or click HERE

STEP2:If you are using k2 5.0 see the bellow link:

https://help.k2.com/onlinehelp/k2five/userguide/5.0/default.htm#K2_Management_Site/Workflow_Server/Rights.htm

or click HERE

Step3:If you are using k2 5.1 see the bellow link:

https://help.k2.com/onlinehelp/k2five/userguide/5.1/default.htm#K2-Workflow-Designer/Permissions/Permissions.htm

or click HERE

https://help.k2.com/onlinehelp/k2five/userguide/5.1/default.htm#K2-Management-Site/Environment-Library/Environment_Library.htm#Environment_Library

or click HERE

 

If this article is helpful to you dont forget to mark it as both solution and kudos or kudos only

 

Regards

Elvis

 

 

Hello Joao,

 

Have you figured this out? If yes, please could you share with us how you resolved the issue.

 

If not, try to check this out..In management site (Logged in as Administrator), expand the following folders in the following order Categories -> System -> Management  and then CLICK on "Categories" to highlight it, and then scroll down to the security section and observe if all the rights have been set to "Allow" or "Inherited Allow". After setting the rights  to "Allow", refresh and check if the other users can now see the Categories Tab as desired.

 

Please provide feedback after performing the above steps and please dont forget to provide this post  with "Mark As Solution" or "Kudo" should it be helpful in resolving the issue.

 

Also, may I please advice you to perform any changes on the development environment before you can do so on the production environment.

 

Regards,

Katleho

 

Reply