Solved

K2 Management and workspace not loading properly

  • 28 May 2020
  • 5 replies
  • 197 views

Badge +4

K2 Management and workspace are not loading properly. Please refer to the screenshot. Can anyone help on this?

icon

Best answer by Mivaro 2 June 2020, 02:05

Hello  @pnelli 


 


I believe this issue was resolved by doing the following actions:


 


1. On the server where Smartforms is installed, navigate to the following folder:


[K2 Install drive]K2K2 smartforms RuntimeContent


2. Ensure that the K2 service account has permissions on the folder above and that the permissions are inherited by objects created inside the folder: 


3. Ensure that you backup the files before making any changes. You can do this by copying all the contents of the "[K2 Install drive]K2K2 smartforms RuntimeContent" folder and paste it outside the K2 folder (eg. Desktop, archive folder, backup folder)


4. Clear the contents of the [K2 Install drive]K2K2 smartforms RuntimeContent folder.5. Once done open your web browsers (e. IE , Chrome)


6. Clear browser cache on web browser


7. Open a new browser


8. Access your K2 sites and check if issue is resolved


 


For future references: please schedule downtime if you perform the above steps as a warm up from IIS is required after these actions have been completed. 


 


Regards,


Michelle

View original

5 replies


Follow the steps below to stop your running process instances:


1. Stop your K2 service


2. Create a backup of your K2 database


3. On your K2 database, run the following, then export the results somewhere. You will need this list to determine which process instances to restart later.


 


For consolidated database:


SELECT * FROM [Server].[ProcInst] WHERE [Status] = 1


If you have multiple K2 databases:


SELECT * FROM [K2Server].[dbo].[_ProcInst] WHERE [Status] = 1


4. On your K2 database, run the following. Note this will stop all process instances, including those started on 18, 19 and 20 Nov:


 


For consolidated database:


UPDATE [Server].[ProcInst]
SET [Status] = 4
WHERE [Status] = 1


 


If you have multiple K2 databases,


UPDATE [K2Server].[dbo].[_ProcInst]
SET [Status] = 4
WHERE [Status] = 1


5. Restart your K2 blackpearl service


6. Check if your Workspace loads properly


 


The above steps will only stop your process instances, not remove them. You can restart those instances by:


1. Go to K2 Workspace > Management Console


2. Expand Workflow Server > Processes


3. Find the Project name your workflow is in, and expand it


4. Find the workflow name, and expand it


5. Select Instances. You should see a list of process instances for that workflow.


6. Look for the instances that is stopped, select it, and restart it. Start by restarting the most recent process instances. For this, you can refer to the results (refer to Folio column) you exported earlier to quickly identify the instance you are looking for.


7. Once you have restarted one process instance, monitor if its status changes. You can keep running the same SELECT query above at intervals to monitor that instance. The moment it is no longer in 'Running' state (Status=1), it should not appear in the list.


8. Once you confirm that instance is no longer in 'Running' state, move on to the next stopped process instance, restart it, and monitor again.


9. If you find a process instance that is stuck again, you can use Workspace to stop it.

Badge +4
How is this, related my issue?
Userlevel 6
Badge +15

Hi pnelli,


 


The issue might be related to TLS setting on the OS. Please have a have look at this KB (https://help.k2.com/products/kbs100249). Alternatively, you can try to disable Usebundles setting to see if that will help.


 

Badge +8

What browser are you using? 

Userlevel 1
Badge +4

Hello  @pnelli 


 


I believe this issue was resolved by doing the following actions:


 


1. On the server where Smartforms is installed, navigate to the following folder:


[K2 Install drive]K2K2 smartforms RuntimeContent


2. Ensure that the K2 service account has permissions on the folder above and that the permissions are inherited by objects created inside the folder: 


3. Ensure that you backup the files before making any changes. You can do this by copying all the contents of the "[K2 Install drive]K2K2 smartforms RuntimeContent" folder and paste it outside the K2 folder (eg. Desktop, archive folder, backup folder)


4. Clear the contents of the [K2 Install drive]K2K2 smartforms RuntimeContent folder.5. Once done open your web browsers (e. IE , Chrome)


6. Clear browser cache on web browser


7. Open a new browser


8. Access your K2 sites and check if issue is resolved


 


For future references: please schedule downtime if you perform the above steps as a warm up from IIS is required after these actions have been completed. 


 


Regards,


Michelle

Reply