Question

Columns added to SharePoint List not available in workflow

  • 2 April 2020
  • 3 replies
  • 178 views

I have a K2 workflow triggered by the creation of an item in a SharePoint list.  The workflow pulls some information from the new item and sends an email to an individual named in the new item.  Works great.  Now I've added a column to the SharePoint list and want to include the data in that column in the email generated by the workflow, but the new column does not appear in the Reference list in K2 Designer.  I've had a lot of experience with SharePoint workflow in SharePoint Designer, and in this situation there was a mechanism to update the list information and make the new column available to the workflow.  I don't see anything like that in K2.  Is there a way to include the new column in the workflow?  Any suggestions would be appreciated!


3 replies

Hi PetrusRomanus


 


Please check if the following is related to your issue.


https://community.k2.com/t5/K2-blackpearl-Articles/SharePoint-Hidden-columns/ta-p/77716


(


SharePoint Hidden columns


Symptoms


SharePoint Hidden columns


 


Diagnoses


 


I want to be able to set a value of a hidden column in a sharepoint list in a K2 for SharePoint workflow. Seems that the column is not available when set to hidden. We need to make the column hidden so that it is not available on the SharePoint out of the box forms, we do not want the user to be able to update this column.


 


Resolution


Set the Field to Visible during the Design Process, once the Process has been deployed you can set the Field back to Hidden and the Workflow will still update it during Runtime


)


 


Best,


Sunrise

Thanks for getting back to me but this is not the issue i'm having.  It's not hidden in SharePoint. It was added to the list after I built the K2 workflow and K2 does not see it so I can't use it in the workflow.  The new field does not appear in the References list in K2.

You will need to regenerate the SmartObjects by going to K2 App on the list view and click on 'Regenerate SmartObjects'. see attachment

 

 

 

Thanks,

Mehul


Reply