Solved

Unable to Access Workflow Rest API K2 cloud

  • 25 March 2020
  • 4 replies
  • 209 views

the user is unable to open up the swagger definition and cannot log in with the credentials provided in k2 cloud.

icon

Best answer by Dumisani 30 March 2020, 11:04

Good day ProInception,

 

Are you making use of an Azure Active Directory account?

 

If that's the case then you cannot log in to the WorkFlow REST API and the SmartObject OData using Basic Authentication with an Azure Active Directory account that has multi-Factor Authentication (MFA) enabled. Turin off Multi-Factor Authentication before granting consent. You can then turn MFA back on once consent has been granted.

 

Additionally please note that if you are authenticating with Azure Active Directory (AAD), you will need to grant consent for K2 to access AAD by clicking the SETUP AAD CONSENT button on the Integration > APIs node. See API Configuration for more information.

For more information see Authentication with the Workflow REST API.

 

Referencing:

https://help.k2.com/onlinehelp/k2cloud/userguide/Update_11/default.htm#K2-Management-Site/Integration/Workflow-REST-API.htm%3FTocPath%3DAdminister%7CK2%2520Management%7CIntegration%7CAPI%2520Configuration%7C_____1

 

Best regards,

Dumisani

 

View original

4 replies

Userlevel 2
Badge +4

Hi there  @ProInception 


 


To resolve this, you need to add the user under the local security policy. You can navigate here by following this path:


Start menu > Local Security policy > Local Policies > User Rights Management > Log on as Batch Job


When completed, the user should be able to open up the swagger definition as expected. 


 


Have a look at the following link :


https://help.k2.com/support-services/kbt147579


 


I hope this was helpful


 


regards


HulisaniN

This is not the correct solution. we are using the k2 cloud.

Good day ProInception


 


See the following.



 


Best,


Sunrise

Userlevel 3

Good day ProInception,

 

Are you making use of an Azure Active Directory account?

 

If that's the case then you cannot log in to the WorkFlow REST API and the SmartObject OData using Basic Authentication with an Azure Active Directory account that has multi-Factor Authentication (MFA) enabled. Turin off Multi-Factor Authentication before granting consent. You can then turn MFA back on once consent has been granted.

 

Additionally please note that if you are authenticating with Azure Active Directory (AAD), you will need to grant consent for K2 to access AAD by clicking the SETUP AAD CONSENT button on the Integration > APIs node. See API Configuration for more information.

For more information see Authentication with the Workflow REST API.

 

Referencing:

https://help.k2.com/onlinehelp/k2cloud/userguide/Update_11/default.htm#K2-Management-Site/Integration/Workflow-REST-API.htm%3FTocPath%3DAdminister%7CK2%2520Management%7CIntegration%7CAPI%2520Configuration%7C_____1

 

Best regards,

Dumisani

 

Reply